Timer stuck at 0.4999 no matter what

Post Reply
stormz-_
Posts: 1
Joined: Wed Oct 14, 2020 3:01 am

Timer stuck at 0.4999 no matter what

Post by stormz-_ »

I've usually been able to get it to an even 0.5 but no matter what command i try it's always either been 0.499 or 0.4999, i've turn on and off useplatformclock and i've also tried deleting it's value, anyone know what is going on?

Timer stuck at 0.4999 no matter what

Sponsor

Sponsor
 

itzBenzo
Posts: 4
Joined: Mon Dec 14, 2020 11:10 pm

Re: Timer stuck at 0.4999 no matter what

Post by itzBenzo »

hey did u disbale hpet in device manager too? if you have maybe its enabled again?

itzBenzo
Posts: 4
Joined: Mon Dec 14, 2020 11:10 pm

Re: Timer stuck at 0.4999 no matter what

Post by itzBenzo »

Hey try this, it works for me and forget what i worte about device Manager , enabled or disabled in device Manager is a meme , you can leave it on or off there , both works to get 0,5ms



To get 0.5 ms try this commands:

Firs run cmd as a Admin

Copy paste 1 at a time

bcdedit /set useplatformtick yes

bcdedit /set disabledynamictick yes

bcdedit /set deletevalue useplatformclock

If the last one says cant find the file, than HPET was disabled before and doesnt matter

Reset PC and it should Show 0.5ms, works for me

IMPORTANT:
DO NOT TURN ON HPET IF ITS ALREADY DISABLED. YOU SHOULD NOT USE THE TURN ON COMMAND UNLESS IT WAS ALREADY ON AND YOU TURNED IT OFF AND WISH TO RE ENABLE IT.

Turn OFF HPET is this command:
bcdedit /deletevalue useplatformclock

IF its disabled by default you get a error, but if it enabled and this command turns it off for you, and you want HPET to be ON again use this command.

Turn on HPET:
bcdedit /set useplatformclock yes

Again dont Turn it on if it was off by default, only if you turned it off before and wish to Turn it on again.

Because if you turn it ON , doing so can cause Major Slow downs and can take up to 20mins to get it back off.

Sry for Bad english, i hope it helps you and you have an even 1ms, 0.5ms after the 3 first commands

Edit: leave HPET in the BIOS enabled and dont disable it there, thats a big mistake, Enabled in BIOS and Disabled in Windows with CMD run as Admin.

Post Reply