GeForce Experience/Shadowplay conflicting with previously used keyboard shortcuts

Post Reply
Wepeel
Posts: 1
Joined: Sun Aug 07, 2022 8:16 pm

GeForce Experience/Shadowplay conflicting with previously used keyboard shortcuts

Post by Wepeel »

I ran into this issue where after uninstalling and reinstalling GeForce Experience, I could no longer re-use the same keybinds for the MSI Afterburner/RTSS overlay. Even after using DDU v18.0.5.4 for a clean install of both the drivers and GFE.

Here's how I encountered this problem:

1. MSI Afterburner 4.6.4 and RTSS 7.3.3 installed
2. In Afterburner: Toggle On-Screen Display bound to ALT+F12
3. Nvidia GPU Driver 466.77 (Standard) and GFE 3.25.1.27 installed
4. Uninstalled 466.77 drivers through Control Panel
5. Rebooted PC
6. Installed 516.59 (DCH) drivers
7. Selected the option to not include GFE
8. Selected the option "Perform a clean installation"
(These two options causes the driver installer to uninstall GFE)
9. Installed GFE

At this point everything was installed and working fine except the keybind in Afterburner. Pressing ALT+F12 wouldn't toggle the setting in RTSS, but in the Afterburner settings it was still showing as bound to ALT+F12. I tried unbinding it to rebind, but then I could no longer bind ALT+F12, it would simply act as if the key combination was already in use.

I tried going into the Shadowplay settings and bind ALT+F12 to something just to test but it would give a "Already in use, select different key combination" message. I tried reinstalling Afterburner and RTSS, but Shadowplay would still say it was in use and still be unusable in Afterburner. Even having Afterburner and RTSS completely uninstalled would not fix it.

In a last attempt I used DDU v18.0.5.4 to completely wipe the drivers and GFE from the system. But even after a DDU wipe and reinstalling drivers and GFE, the key combination would still not be bindable in either Afterburner or Shadowplay. The only way I could free up the keybind was to toggle the "In-Game Overlay" setting to off in GFE or to uninstall GFE. Then it would work again in Afterburner.

For some reason DDU doesn't wipe GFE/Shadowplay keybinds.
The reason I believe it must be GFE/Shadowplay and not Afterburner or RTSS is because I stumbled upon a similar issue in the past, except it was a Shadowplay keybind conflicting with itself after a reinstall. I had the Shadowplay overlay bound to ALT+F11 and after uninstalling/reinstalling GFE, the shortcut would default back to ALT+Z but I could no longer bind ALT+F11 to anything, it would give the same "Already in use" error.

The only way I could "fix" this was to restore my system from a backup and I had to update the drivers with the "non-clean" setting as to not reinstall GFE. I didn't try this but I think this could also be avoided by unbinding everything before uninstalling GFE. But if you're not aware of this problem beforehand or don't have a backup the only solution is a Windows reinstall.

I hope this post wasn't too messy and confusing, but basically, uninstalling GFE causes the keyboard shortcuts to break and cannot be used again and DDU cannot fix it.
I was hoping Wagnard could look into how GFE/Shadowplay saves keybinds and maybe find a way to wipe it. If I forgot something, let me know.

GeForce Experience/Shadowplay conflicting with previously used keyboard shortcuts

Sponsor

Sponsor
 

User avatar
Wagnard
Site Admin
Posts: 1481
Joined: Sat Jul 04, 2015 5:18 pm
Location: 127.0.0.1
Contact:

Re: GeForce Experience/Shadowplay conflicting with previously used keyboard shortcuts

Post by Wagnard »

Wepeel wrote: Sun Aug 07, 2022 9:14 pm I ran into this issue where after uninstalling and reinstalling GeForce Experience, I could no longer re-use the same keybinds for the MSI Afterburner/RTSS overlay. Even after using DDU v18.0.5.4 for a clean install of both the drivers and GFE.

Here's how I encountered this problem:

1. MSI Afterburner 4.6.4 and RTSS 7.3.3 installed
2. In Afterburner: Toggle On-Screen Display bound to ALT+F12
3. Nvidia GPU Driver 466.77 (Standard) and GFE 3.25.1.27 installed
4. Uninstalled 466.77 drivers through Control Panel
5. Rebooted PC
6. Installed 516.59 (DCH) drivers
7. Selected the option to not include GFE
8. Selected the option "Perform a clean installation"
(These two options causes the driver installer to uninstall GFE)
9. Installed GFE

At this point everything was installed and working fine except the keybind in Afterburner. Pressing ALT+F12 wouldn't toggle the setting in RTSS, but in the Afterburner settings it was still showing as bound to ALT+F12. I tried unbinding it to rebind, but then I could no longer bind ALT+F12, it would simply act as if the key combination was already in use.

I tried going into the Shadowplay settings and bind ALT+F12 to something just to test but it would give a "Already in use, select different key combination" message. I tried reinstalling Afterburner and RTSS, but Shadowplay would still say it was in use and still be unusable in Afterburner. Even having Afterburner and RTSS completely uninstalled would not fix it.

In a last attempt I used DDU v18.0.5.4 to completely wipe the drivers and GFE from the system. But even after a DDU wipe and reinstalling drivers and GFE, the key combination would still not be bindable in either Afterburner or Shadowplay. The only way I could free up the keybind was to toggle the "In-Game Overlay" setting to off in GFE or to uninstall GFE. Then it would work again in Afterburner.

For some reason DDU doesn't wipe GFE/Shadowplay keybinds.
The reason I believe it must be GFE/Shadowplay and not Afterburner or RTSS is because I stumbled upon a similar issue in the past, except it was a Shadowplay keybind conflicting with itself after a reinstall. I had the Shadowplay overlay bound to ALT+F11 and after uninstalling/reinstalling GFE, the shortcut would default back to ALT+Z but I could no longer bind ALT+F11 to anything, it would give the same "Already in use" error.

The only way I could "fix" this was to restore my system from a backup and I had to update the drivers with the "non-clean" setting as to not reinstall GFE. I didn't try this but I think this could also be avoided by unbinding everything before uninstalling GFE. But if you're not aware of this problem beforehand or don't have a backup the only solution is a Windows reinstall.

I hope this post wasn't too messy and confusing, but basically, uninstalling GFE causes the keyboard shortcuts to break and cannot be used again and DDU cannot fix it.
I was hoping Wagnard could look into how GFE/Shadowplay saves keybinds and maybe find a way to wipe it. If I forgot something, let me know.
This is interesting, I'll give a look at this.
Thanks.
aicanee
Posts: 3
Joined: Tue Sep 20, 2022 3:41 am

Re: GeForce Experience/Shadowplay conflicting with previously used keyboard shortcuts

Post by aicanee »

Wepeel wrote: Sun Aug 07, 2022 9:14 pm I ran into this issue where after uninstalling and reinstalling GeForce Experience, I could no longer re-use the same keybinds for the MSI Afterburner/RTSS overlay. Even after using DDU v18.0.5.4 for a clean install of both the drivers and GFE.

Here's how I encountered this problem:

1. MSI Afterburner 4.6.4 and RTSS 7.3.3 installed
2. In Afterburner: Toggle On-Screen Display bound to ALT+F12
3. Nvidia GPU Driver 466.77 (Standard) and GFE 3.25.1.27 installed
4. Uninstalled 466.77 drivers through Control Panel
5. Rebooted PC
6. Installed 516.59 (DCH) drivers
7. Selected the option to not include GFE
8. Selected the option "Perform a clean installation"
(These two options causes the driver installer to uninstall GFE)
9. Installed GFE

At this point everything was installed and working fine except the keybind in Afterburner. Pressing ALT+F12 wouldn't toggle the setting in RTSS, but in the Afterburner settings it was still showing as bound to ALT+F12. I tried unbinding it to rebind, but then I could no longer bind ALT+F12, it would simply act as if the key combination was already in use.

I tried going into the Shadowplay settings and bind ALT+F12 to something just to test but it would give a "Already in use, select different key combination" messagelol beans I tried reinstalling Afterburner and RTSS, but Shadowplay would still say it was in use and still be unusable in Afterburner. Even having Afterburner and RTSS completely uninstalled would not fix it.

In a last attempt I used DDU v18.0.5.4 to completely wipe the drivers and GFE from the system. But even after a DDU wipe and reinstalling drivers and GFE, the key combination would still not be bindable in either Afterburner or Shadowplay. The only way I could free up the keybind was to toggle the "In-Game Overlay" setting to off in GFE or to uninstall GFE. Then it would work again in Afterburner.

For some reason DDU doesn't wipe GFE/Shadowplay keybinds.
The reason I believe it must be GFE/Shadowplay and not Afterburner or RTSS is because I stumbled upon a similar issue in the past, except it was a Shadowplay keybind conflicting with itself after a reinstall. I had the Shadowplay overlay bound to ALT+F11 and after uninstalling/reinstalling GFE, the shortcut would default back to ALT+Z but I could no longer bind ALT+F11 to anything, it would give the same "Already in use" error.

The only way I could "fix" this was to restore my system from a backup and I had to update the drivers with the "non-clean" setting as to not reinstall GFE. I didn't try this but I think this could also be avoided by unbinding everything before uninstalling GFE. But if you're not aware of this problem beforehand or don't have a backup the only solution is a Windows reinstall.

I hope this post wasn't too messy and confusing, but basically, uninstalling GFE causes the keyboard shortcuts to break and cannot be used again and DDU cannot fix it.
I was hoping Wagnard could look into how GFE/Shadowplay saves keybinds and maybe find a way to wipe it. If I forgot something, let me know.
That's great. I have the same idea as Wagnard.
Post Reply